Di seguito le istruzioni per la preparazione e la configurazione del router/gateway. La configurazione è generica ed è in generale adattabile a qualsiasi modello di Mikrotik sul quale giri RouterOS.

Quello dal quale è tratta è il modello hAP ac lite RB952Ui-5ac2nD.

Attenzione: questa procedura è valida per tutti gli apparati Mikrotik che HANNO una cartella chiamata “flash” precaricata sul file system.

Si da per scontato che l'apprato sia configurato per poter accedere ad internet attraverso una interfaccia.


A prescindere dal modello utilizzato l’unico vincolo di configurazione non aggirabile è la necessità che la porta ether2 sia riservata a noi.

Se non esiste una porta con tale nome è necessario rinominare una delle porta esistenti oppure crearne una virtuale.

Queste verrà associata (dai nostri script) ad un bridge di nome “hotspot” su cui sarà connessa la rete degli ospiti.

Successivamente a tale bridge si potranno associare altre porte a seconda delle singole esigenze.



Eliminazione configurazioni preesistenti


  • Verificare che le interfacce Wi-Fi (se esistenti) siano nominate “wlanN” (Interfaces > Interface > Name)
  • Eliminare eventuali liste di interfacce configurate, fatta eccezione per quelle non rimovibili (Interfaces > Interface List > Lists)
  • Eliminare eventuali hotspot configurati, eccetto il default che non è rimovibile (IP > Hotspot > Server Profiles)
  • Eliminare eventuali IP Hotspot (IP > Hotspot > Servers)
  • Eliminare eventuali IP Pool (IP > Pool)
  • Eliminare eventuali DHCP server (IP > DHCP Server)
  • Eliminare eventuali bridge port (Bridge > Ports)
  • Eliminare eventuali regole firewall (IP > Firewall > Filter Rules)
  • Eliminare eventuali regole NAT (IP > Firewall > NAT)


Attivazione del provisioning WFH/WFY (assumendo WAN con DHCP)

- Su Interface->Interface List Creare una lista nominata “WAN” e mettere in tale lista la porta utilizzata per connettere a internet l’apparato

- Su System -> Packages -> Check For Updates -> Download&Install (per aggiornare SW) – Attendere il riavvio dell’apparato e rientrare via web

- Con un client SFTP oppure via WinBox caricare file provisioning (expflash.rsc) e file licenza (licence, da non rinominare e da richiedere a noi per ogni gw si voglia attivare) DENTRO la directory >Flash.

-- Da terminale copiare/eseguire i seguenti comandi


/interface bridge

add fast-forward=no name=bridge

/ip firewall filter

add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes

/ip firewall nat

add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes

add action=masquerade chain=srcnat out-interface-list=WAN

/system scheduler

add interval=10m name=hotspot on-event="/import /flash/expflash.rsc"

 

Eventuali errori relativi ad interfacce già presenti possono essere ignorati


Terminata la procedura, accedere al pannello di controllo di Wi-Fi Hotel/WiFinity dopo aver attivato la location tramite il link ricevuto via mail, associare il gateway appena configurato alla location (Impostazioni > Location > Gestione Gateway > Nuovo Gateway) utilizzando il seguente codice di attivazione (da richiedere a noi per ogni gateway si voglia associare):


L' ACTIVATION CODE corrisponde al codice presente nel file di licenza caricato sul gateway stesso.


Nel giro di qualche minuto (fino a 15 minuti) il gw scaricherà il provisioning e sarà controllato dal pannello di controllo. È possibile verificare l’avvenuto provisioning guardando i log dell’apparato (Sezione “log”).

Si noti che anche la pw dell’apparato cambierà. Richiederla a noi se necessario.